Fix “This field was locked by vendor” in Plesk Updates source and installation settings

I was trying to install some new components to one on my Plesk managed servers but I got this error when going to “Server > Tools & Settings > Plesk > Updates and Upgrades”:

Failed to read product information from the file : Can't process products.inf3: Failed to download the package http://20141204-09h35m01s.parallels.mirrors.ovh.net.snapmirror.vps.ovh.net/parallels/products.inf3: The requested URL returned error: 404 Can't process versions.inf3: Failed to download the package http://20141204-09h35m01s.parallels.mirrors.ovh.net.snapmirror.vps.ovh.net/parallels/versions.inf3: The requested URL returned error: 404

I asked OVH technical service and they told me more or less this: “Yep, that URL is no longer available but we only provide it on first automated install. Fix it yourself.”. I have to say that this happened with the customer service from Spain, something that of course didn’t surprise me. We are used to this kind of “help” from customer services here.

So I tried to change the product information source to the official Plesk one but I noticed that the field was disabled, as it said “This field was locked by vendor.”.

Plesk-updates-source-and-installation-settings

I started to search for the original URL in /root/parallels in order to edit it with no luck. When I did a search for this problem on the Internet I got to the most surreal fix I’ve ever come around: Open the browsers devtools and remove the “disabled” option to the “URL to the directory with .inf3 file” input field, change the URL to the correct one (http://parallels.mirrors.ovh.net/parallels/) and click “Save”. It worked!

Plesk-updates-source-and-installation-settings-before

Plesk-updates-source-and-installation-settings-after

Ref: http://forum.odin.com/threads/where-is-the-parallels-installer-configuration-file.329704/#post-782253

You might also like

Fix “There is no suitable CSPRNG installed on your system” in Plesk
After updating paragonie/random_compat you may get this error. This is caused because version 2.0 stopped...

Adding PHP 7.0 support in Plesk
First thing you need to do is update to Plesk 12.5 (currently 12.5.30). For that you have to go to Server...

Fix “Configuration of pmadb… not OK” in phpMyAdmin
You may get this message in pmpMyAdmin:To fix this you have to import/create the phpmyadmin database...

CentOS “Error: php-mysql conflicts with php-mysqlnd” updating with PHP 7.0
If you get an error about a conflict between php-mysql and php-mysqlnd when updating CentOS packages...

  1. Just wanted to say that this worked brilliantly. So simple it’s dumb. Thanks!

Leave a Comment

This site uses Akismet to reduce spam. Learn how your comment data is processed.