Compilar ffmpeg con soporte libfdk_aac: codificando AAC con ffmpeg

Quería añadir el soporte para la librería libfdk_aac a ffmpeg porque la documentación dice que es la mejor opción para la codificación con AAC.

ffmpeg-logo

El problema es que al configurar ffmpeg con el flag “–enable-libfdk-aac” para usar libfdk_aac me daba este error:

Unknown option "--enable-libfdk-aac".
See ./configure --help for available options.

Estaba compilando lo que yo creía que era la última versión disposible de ffmpeg (0.11.5) en la web de releases y ese fue el gran fallo: la última versión disponible es la 2.3.3 y además ffmpeg usa ahora git. Así que clone el repositorio y entonces el flag “–enable-libfdk-aac” funcionó perfecto:

git clone git://source.ffmpeg.org/ffmpeg.git ffmpeg

Si quieres comprobar que se ha activado el soporte para libfdk_aac look busca la siguiente línea en la sección “Enabled encoders” al configurar ffmpeg:

a64multi5          libfdk_aac         prores

You might also like

Instalar OpenSceneGraph 2.9.6 con soporte para Collada en Ubuntu 12.04
Aunque normalmente uso OpenSceneGraph 2.8.3 para trabajar con osgART 2.0 RC3 también se puede usar OpenSceneGraph...

Instalar OpenSceneGraph 2.8.3 con soporte para Collada en Ubuntu 12.04
Vamos a instalar OpenSceneGraph 2.8.3 (de ahora en adelante OSG) para usarlo con osgART 2.0 RC3. Hasta...

Instalar OpenCV 2.4.2 con soporte para ffmpeg en Mac OS X 10.8
Para instalar OpenCV 2.4.2 con soporte ffmpeg tenemos que instalar primero lamemp3, faac, faad y por...

Instalar OpenCV 2.3.1a en Ubuntu 11.10
Para instalar la versión 2.1 desde los repositorios ejecutar: sudo apt-get install libcv-dev libcv2.1...

Dejar un comentario?

0 Comentarios.

Deje un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.