Arreglar “This field was locked by vendor” en Plesk Updates source and installation settings

Estaba intentando instalar unos nuevos componentes a uno de mis servidores gestionados con Plesk pero vi que aparecía el siguiente error al ir a “Server > Tools & Settings > Plesk > Updates and Upgrades”:

Failed to read product information from the file : Can't process products.inf3: Failed to download the package http://20141204-09h35m01s.parallels.mirrors.ovh.net.snapmirror.vps.ovh.net/parallels/products.inf3: The requested URL returned error: 404 Can't process versions.inf3: Failed to download the package http://20141204-09h35m01s.parallels.mirrors.ovh.net.snapmirror.vps.ovh.net/parallels/versions.inf3: The requested URL returned error: 404

Prengunté al servicio técnico de OVH y más o menos me dijeron esto: “Sip, esa URL ya no existe y solo es válida cuando se instala la primera vez de forma automática. Arréglalo tú mismo.”. Tengo que decir que esto fue con el servicio técnico de España, algo que por supuesto no me sorprendió. Estamos acostumbrados a este tipo de “ayuda” por aquí.

Así que intenté modificar la información de origne de Plesk pero vi que el campo estaba deshabilitado y se podía leer “This field was locked by vendor.”.

Plesk-updates-source-and-installation-settings

Me puse a buscar dentro de /root/parallels a ver si encontraba la URL a modificar pero no hubo suerte. Al buscar este problema por internet encontré una de las soluciones más surrealistas que he visto en mi vida: Abrir el devtools del navegador, quitar el atributo “disabled” al campo “URL to the directory with .inf3 file”, poner el valor de la URL correcta y hacer click en “Save”. ¡Y funcionó!

Plesk-updates-source-and-installation-settings-before

Plesk-updates-source-and-installation-settings-after

Ref: http://forum.odin.com/threads/where-is-the-parallels-installer-configuration-file.329704/#post-782253

You might also like

Arreglar “There is no suitable CSPRNG installed on your system” en Plesk
Después de actualizar paragonie/random_compat puede que te aparezca ese error. Esto se debe a que a...

Añadiendo soporte para PHP 7.0 en Plesk
Lo primero que hay que hacer es actualizar Plesk a la version 12.5 (actualmente la 12.5.30). Para ello...

SonataAdminBundle: Arreglar “The “ batch action is not defined” at app/vendor/sonata-project/admin-bundle/Controller/CRUDController.php in a shared hosting: magic_quotes_gpc
Estaba teniendo errores http 500 al borrar entidades en SonataAdminBundle usando el batch mode (es decir...

Scripts para instalar ARToolKit, Collada DOM, OpenSceneGraph y osgART
He creado unos scripts y parches para que la instalación de todas estas librerías sean menos "dolorosa"....

Dejar un comentario?

0 Comentarios.

Deje un comentario

Este sitio usa Akismet para reducir el spam. Aprende cómo se procesan los datos de tus comentarios.